【事象の概要】
現在、Microsoft 365 で Gluegent Flow をお使いの一部のお客様環境にて、下記事象が発生しています。
- グループ選択パネルでグループメンバーが表示されない
全社
└Aグループ
└ユーザー1(表示されない)
- ユーザー名、処理者名がメールアドレスとして表示される
【原因】
Gluegent Flow では1日1回実行されるグループキャッシュの更新処理にて Microsoft 365 のユーザー・グループ情報を取得し、Gluegent Flow に登録しています。
ユーザー・グループ情報の取得は API を使用していますが、この API の結果が正しくないようです。
【回避策】
Microsoft 365 側の API の一時的な不具合の可能性のため、Gluegent Flow 側での対応は難しい状況です。
グループキャッシュの更新処理をお客様ご自身で実施できる設定の場合は、時間をおいてグループキャッシュの更新処理を実施いただくことで解消する場合があります。
お客様ご自身で実施できない設定の場合は、当サポートへご依頼ください。
お客様にはご迷惑をおかけしており、申し訳ございません。
【2021/06/14 9:25 追記】
6 月 11 日時点で解消したようで、複数のお客様からグループキャッシュの更新処理の再実行で正常に表示されるとのご報告をいただいておりました。
しかし、6 月 12 日以降のグループキャッシュの更新処理で同様の事象が再発し、本日時点でも継続して発生しているようです。
現在、引き続き調査を行っております。
【2021/06/14 13:20 追記】
Microsoft 365 側の API の変更があったようで、Gluegent Flow 側で対応を検討しております。対応完了には時間がかかるため、暫定対応として、6 月 12 日深夜時点のバックアップからユーザー・グループ情報を復元いたします。
データの復元は影響があったお客様環境に順次反映しておりますので、今しばらくお待ちください。
【2021/06/14 17:10 追記】
Microsoft 365 の API の変更は仕様変更によるものでした。現在、Gluegent Flow 側の対応を行っております。
対応完了までの間、上記の暫定対応を実施したお客様環境ではグループキャッシュの更新処理を一時的に停止しております。
また、API の仕様変更による影響で、初期設定画面にアクセスした際、管理者情報が取得できず、「このページはApps管理者のみ使用できます」というメッセージが表示されます。こちらも対応中でございます。
引き続きご不便をおかけいたしますが、今しばらくお待ちください。
【2021/06/15 9:35 追記】
今回の不具合の原因として、ユーザー・グループ情報の取得時に API が返すエラーを正しく判断できず成功として処理している部分がございました。
昨夜ホットフィックスリリースを実施し、この原因部分を修正いたしました。
このリリースにより暫定対応により停止していたグループキャッシュの更新処理を再開いたしました。
ユーザー・グループ情報を含め、API アクセスに関する問題については引き続き対応を行っております。
【2021/06/16 10:03 追記】
昨夜ホットフィックスリリースを実施し、本件の根本対応を実施いたしました。
このリリースにより本件は解消しております。ご不便をおかけし、申し訳ございませんでした。
なお、一部のお客様環境におきましては、初期設定にてシステムユーザーの再指定を行う必要があります。
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6 月 11 日時点で解消したようで、複数のお客様からグループキャッシュの更新処理の再実行で正常に表示されるとのご報告をいただいておりました。
しかし、6 月 12 日以降のグループキャッシュの更新処理で同様の事象が再発し、本日時点でも継続して発生しているようです。
現在、引き続き調査を行っております。
Microsoft 365 側の API の変更があったようで、Gluegent Flow 側で対応を検討しております。対応完了には時間がかかるため、暫定対応として、6 月 12 日深夜時点のバックアップからユーザー・グループ情報を復元いたします。
データの復元は影響があったお客様環境に順次反映しておりますので、今しばらくお待ちください。
Microsoft 365 の API の変更は仕様変更によるものでした。現在、Gluegent Flow 側の対応を行っております。
対応完了までの間、上記の暫定対応を実施したお客様環境ではグループキャッシュの更新処理を一時的に停止しております。
また、API の仕様変更による影響で、初期設定画面にアクセスした際、管理者情報が取得できず、「このページはApps管理者のみ使用できます」というメッセージが表示されます。こちらも対応中でございます。
引き続きご不便をおかけいたしますが、今しばらくお待ちください。
今回の不具合の原因として、ユーザー・グループ情報の取得時に API が返すエラーを正しく判断できず成功として処理している部分がございました。
昨夜ホットフィックスリリースを実施し、この原因部分を修正いたしました。
このリリースにより暫定対応により停止していたグループキャッシュの更新処理を再開いたしました。
ユーザー・グループ情報を含め、API アクセスに関する問題については引き続き対応を行っております。
昨夜ホットフィックスリリースを実施し、本件の根本対応を実施いたしました。
このリリースにより本件は解消しております。ご不便をおかけし、申し訳ございませんでした。
なお、一部のお客様環境におきましては、初期設定にてシステムユーザーの再指定を行う必要があります。
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