Gluegent Gate から Microsoft 365 へID同期を行う際に、特定のライセンスが原因で同期に失敗し、
「Authorization_RequestDenied」というエラーが発生する場合があります。
本記事では、この事象の原因と具体的な対処方法について解説します。
1. 事象
Gluegent GateからMicrosoft 365 にID同期をした際に、ライセンスが更新されない。
Gluegent Gate の操作ログに、以下のエラーメッセージが表示されます。
Microsoft Graph API failure: Authorization_RequestDenied - Insufficient privileges to complete the operation.
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操作ログの確認方法は、以下のサポートページをご参照ください。
2. 原因
このエラーは Microsoft 365 側の該当ユーザーに、「セルフサービス」で付与されたライセンスが
ある場合に発生いたします。
(例)
・Teams 試用版(Teams_Premium_(for_Departments)、Microsoft_Teams_Exploratory_Dept など)
・Visio Plan2 試用版(VISIO_PLAN2_DEPT)
3. 対処方法
手順1. エラー範囲の確認:他ユーザーのID同期結果を確認する。
「1. 事象」の確認と同様に、Gluegent Gate の操作ログから他ユーザーの更新状況を確認します。
他のユーザーでは正常にライセンス同期されており、特定のユーザーでのみ発生する場合は、
その特定ユーザーの問題である可能性が高いということになります。
手順2. 原因ライセンスの特定と解除
Microsoft 365 管理センターで、エラーが発生しているユーザーのライセンス情報を確認し、
セルフサービスで付与されたライセンスが割り当てられていれば解除します。
詳細については、以下のMicrosoft サポートページをご参照ください。
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セルフサービスライセンスを持つユーザーの表示方法:
セルフサービス購入または試用版サブスクリプションのライセンスを持つユーザーを表示する | Microsoft Learn
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セルフサービスライセンスの解除(引き継ぎ)方法:
セルフサービス購入または試用版サブスクリプションを引き継ぐ| Microsoft Learn
手順3. Gluegent Gate から 修正内容を反映させる(再同期)
原因となっていたライセンスを解除した後、Gluegent Gateから再度ID同期を実行します。
(1) Gluegent Gate 管理画面で、「ユーザー」 >「一覧」より、対象ユーザーを選択し、
ユーザー情報画面を表示します。
(2) ユーザー情報画面の最下部にある「更新」ボタンをクリックします。
これにより、Microsoft 365への同期処理が再度実行されます。
(3) 再同期結果を確認します。
処理完了後、Gluegent Gate の操作ログでエラーが解消されたことと、Microsoft 365 側で
ライセンスが正しく付与されたことをご確認ください。
4. 「セルフサービス」ライセンスの取り扱いについて
弊社では、エラー原因となるセルフサービスライセンスを確認次第、順次ID同期の対象から
除外する対応を行っております。
しかし、Microsoft 365 のライセンスは今後も新たに追加・変更される可能性があります。
お客様の環境で同様のエラーが確認された場合は、お手数ですが弊社サポートまでご一報ください。
ご報告いただいたライセンス情報をもとに、同期対象外とするための製品アップデートを
継続してまいります。